Degraded delivery to Yahoo mailboxes

Incident Report for mySMTP

Resolved

We have now normal delivery to Yahoo free mails again. We will monitor closely for any disruptions
Posted Aug 20, 2025 - 15:52 CEST

Investigating

We see degraded delivery and blocks for some senders in the infrastructure. We are in contact with Yahoo Postmaster to solve the issue ASAP
Posted Aug 19, 2025 - 08:47 CEST
This incident affected: Deliverability (Yahoo - AOL).