O365 Microsoft email accounts delivery

Incident Report for mySMTP

Resolved

Seems O365 delivery issued has been mitigated in the background. Still some ripple effects might be experienced. At the moment we have no feedback from Microsoft on the issue.
Posted Feb 26, 2026 - 09:53 CET

Investigating

We are aware of degraded delivery via some IPs in the infrastructure. Emails might expire with message:
451 4.7.500 Server busy. Please try again later from [Your outgoing sending IP]
Some other sources indicate they experience same problem in the email sending infrastructure.
When the IP via https://sender.office.com/ is checked for blocking the result is "no problems"
We will closely watch it from here and update as soon its resolved or mitigated from Microsoft side
Posted Feb 25, 2026 - 12:19 CET
This incident affected: Deliverability (Microsoft 365 email accounts).